Error experienced
When running a CI Sync job which includes the “Application Service Mapping” recordset selection, the job fails with:
“User is unauthorized to access table cmdb_ci_service_auto“
Error verification
No other error verification information is applicable.
Cause
This problem occurs because the ServiceNow integration user account does NOT have read access to the cmdb_ci_service_auto table:
Fix
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If the intention is not to create or update Application Services / Service Instances in ServiceNow as part of a CI Sync job (which requires further configuration dependent on the source as per KBs found under CI Sync SaaS and Web UI ) then do not select the “Application Service Mapping” recordset when running a job; OR
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Grant the ServiceNow user account for CI Sync integration the app_service_admin role or contact Syncfish if a custom role is preferred due to your specific requirements.
Related Articles
Control Information
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PUBLIC
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