Troubleshoot - User is unauthorized to access table cmdb_ci_service_auto

Error experienced

When running a CI Sync job which includes the “Application Service Mapping” recordset selection, the job fails with:

“User is unauthorized to access table cmdb_ci_service_auto“

image-20241029-221300.png
This KB applies to:

Applies to Versions

All

Applies to Source Connectors

All source connectors valid for Application Service Mapping integration

Applies to Destination Connectors

ServiceNow

Error verification

No other error verification information is applicable.

Cause

This problem occurs because the ServiceNow integration user account does NOT have read access to the cmdb_ci_service_auto table:

Fix

  1. If the intention is not to create or update Application Services / Service Instances in ServiceNow as part of a CI Sync job (which requires further configuration dependent on the source as per KBs found under CI Sync SaaS and Web UI ) then do not select the “Application Service Mapping” recordset when running a job; OR

  2. Grant the ServiceNow user account for CI Sync integration the app_service_admin role or contact Syncfish if a custom role is preferred due to your specific requirements.

Control Information

Created

Reviewed

Data Classification

PUBLIC
Classified in accordance with the Syncfish Data Classification Framework