Troubleshoot - SN call exceeded timeout value of 80000ms

Error experienced

“SN call exceeded timeout value of 80000ms to process a single REST request”

This KB applies to:

Applies to Versions

All

Applies to Source Connectors

All

Applies to Destination Connectors

ServiceNow

Error verification

No other error verification information is applicable.

Cause

These errors are typically experienced on the Record Writer when submitting the Batch API requests to process insert/update operations.

Fix

If the timeouts are occurring on the Record Writer
→ Reduce the size of the “Write batch size”.
→ The recommended “Write batch size” for ServiceNow is 100.

If the timeouts are occurring on the Record Reader
→ Reduce the size of the “Read batch size”.
→ The recommended “Read batch size” for ServiceNow is 1000.

If the current batch size configuration matches the recommended sizes, the batch sizes should be reduced further, and jobs executed until the SN call exceeded timeout error is eliminated.

These settings can be configured specifically upon request as it is possible to adversely impact operational efficiency if set to inappropriate values.

Please contact Syncfish Support if you would like to adjust these limits.

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Control Information

Created

Reviewed

Data Classification

PUBLIC
Classified in accordance with the Syncfish Data Classification Framework