Troubleshoot - Job errors with HMAC mismatch error

Error experienced

CI Sync Job errors with “HMAC mismatch” error.

This KB applies to:

Applies to Versions

All

Applies to Source Connectors

All

Applies to Destination Connectors

All

Error verification

HMAC configuration errors typically cause jobs to error in the beginning stages, with the agent not being able to validate payloads. Jobs that have errored as a result of this will display an error message stating that payloads have not been able to be validated, with further reason as to why.

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In some cases, jobs may appear to hang and error after a period of inactivity.

You can further confirm this issue is caused by a HMAC mismatch by opening the CISynchronizer Configuration utility. The utility will attempt to validate the connection to the platform and will display any issues.

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Cause

CI Sync uses a shared secret between the server and the agent for the server to sign task payloads so the agent can verify the server’s authenticity. If a key rollover fails, the keys may be out of sync and the agent will no longer trust the payloads received from the server.

Fix

The shared HMAC secret can be manually regenerated through the CI Synchronizer Configuration tool.
Upon opening the Configuration tool, an error message may appear regarding any HMAC issues the agent may be having.

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  1. Under the Test Connection section of the Configuration tool, there should be a Regenerate HMAC button. If this is not present, you may be running an older version of the agent. Please contact Syncfish via Syncfish Support so we can assist.

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  1. Clicking Regenerate HMAC will open a warning prompt, prompting you that regenerating the HMAC value will prevent the worker from communicating with the CI Synchronizer platform and that the newly generated value will need to be updated in the CI Synchronizer platform.

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  1. Once the previous dialogue box has been confirmed, a new window should appear displaying a newly generated HMAC shared secret as well as a hyperlink to the agent connection in your CI Synchronizer instance.

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  1. Copy the HMAC shared secret generated by the configuration tool and paste it into the Update HMAC Value field in the agent connection page and click the Update HMAC button

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  1. Once the value has been updated in the CI Synchronizer platform return to the Configuration utility and click Continue. The HMAC shared secret and connection to the platform should be validated.

Fix verification

You should see a Connection Successfully Validated confirmation.

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Control Information

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Data Classification

PUBLIC
Classified in accordance with the Syncfish Data Classification Framework