Error experienced
The synchronization process is sending a valid company field value, but the field is NOT being updated in ServiceNow
Error verification
If a customer’s CI Sync configuration includes mapping to Company field but no data is seen in this field, an ACL issue is suspected.
In ServiceNow, impersonate the cisync integration account and navigate to a cmdb_ci record.
The company field will show as read-only if the default write ACL for cmdb.company is restricted to the admin role.
Enabling security debugging while impersonating should show the following debug output:
Cause
Default write ACL for cmdb.company is restricted to the admin role.
Fix
Remove the admin role and add the asset role to the cmdb.company/write ACL (i.e. Admin override setting provides admin role with access by default):
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Control Information
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PUBLIC
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