Troubleshoot - CI Sync unable to update company field on cmdb_ci records due to default ACL

Error experienced

The synchronization process is sending a valid company field value, but the field is NOT being updated in ServiceNow

This KB applies to:

Applies to Versions

All

Applies to Source Connectors

All

Applies to Destination Connectors

ServiceNow

Error verification

If a customer’s CI Sync configuration includes mapping to Company field but no data is seen in this field, an ACL issue is suspected.

image-20230315-090838.png

In ServiceNow, impersonate the cisync integration account and navigate to a cmdb_ci record.

The company field will show as read-only if the default write ACL for cmdb.company is restricted to the admin role.

Enabling security debugging while impersonating should show the following debug output:

image-20230315-091218.png

Cause

Default write ACL for cmdb.company is restricted to the admin role.

Fix

Remove the admin role and add the asset role to the cmdb.company/write ACL (i.e. Admin override setting provides admin role with access by default):

image-20260106-055753.png

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Control Information

Created

Reviewed

Data Classification

PUBLIC
Classified in accordance with the Syncfish Data Classification Framework