Troubleshoot - Sync error, cannot resolve the SQL collation conflict

Error experienced

sync error.jpg

Error verification

See in the link to the kb article below Task 3 (SQL): Create a Source System Connection using the CI Sync Agent Config Utility with a SQL RecVer DB.

This error is likely related to the manual creation of the Recver database (MS SQL Setup Option 2) during the initial setup versus using the CI Sync Agent Config Utility to automatically create the RecVer database (MS SQL Setup Option 1).

https://support.syncfish.com.au/cs/appendix-d-how-to-add-lansweeper-it-on-prem-as-a-s#AddLansweeperOn-Prem-Option2:UseyourSQLDatabaseAdministrator(DBA)tomanuallycreatetheRecVerdatabaseinadvance

Cause

  1. The SQL Script used in MS SQL Setup Option 2 (RecVer via DBA steps) relies upon a $(source_database_name) parameter. The DBA needs to amend the script (or use command line parameters) to state the name of the Lansweeper SQL DB (e.g. typically “lansweeperdb” but not always).

  2. The SQL Script logic uses the LS database name to read the collation value of the LS SQL DB and then create the CI Sync RecVer DB to set the same collation (i.e. the CI Sync RecVer DB and Lansweeper DB need to be using the same collation, otherwise you will see this error).

  3. It’s most likely that either a value was not specified for $(source_database_name) or an incorrect value was specified.

Fix

  1. In SQL, drop the RecVer SQL DB (likely called “cisee_recver_lansweeperdb”). Obviously do NOT drop the Lansweeper SQL DB itself.

  2. Re-run the MS SQL Setup Option 2 (Task 3) Create RecVer SQL Script with a valid value for the $(source_database_name).

  3. Re-run the MS SQL Setup Option 2 (Task 4) Update RecVer SQL Script and pass in the $(recver_database_name).

There are currently no related articles.

Control Information

Created

Reviewed

Data Classification

PUBLIC
Classified in accordance with the Syncfish Data Classification Framework