Error experienced
CI Sync is successfully synchronizing switch port records, however when viewing an IP Switch record in ServiceNow, the Switch Ports related list does NOT contain any records.
Error verification
No other error verification information is applicable.
Cause
The Out-of-the-box ServiceNow configuration for the IP Switch Configuration Item related lists includes the “Switchport” [dscy_switchport] table. CI Sync writes switch port records to the “Switch Port“ [cmdb_switch_port] table.
Fix
Reconfigure the related lists for IP Switch:
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In ServiceNow, navigate to any switch record, right-mouse click in the header banner and select Configure/Related Lists.
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Remove dscy_switchport (“Switchport → Configuration Item”) related list from cmdb_ci_ip_switch and replace it with cmdb_switch_port (“Switch Port → CMDB CI”) and click the Save button
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PUBLIC
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