Troubleshoot - CI Sync is synchronizing Switch Ports, but they are not visible in ServiceNow.

Error experienced

CI Sync is successfully synchronizing switch port records, however when viewing an IP Switch record in ServiceNow, the Switch Ports related list does NOT contain any records.

This KB applies to:

Applies to Versions

All

Applies to Source Connectors

All

Applies to Destination Connectors

ServiceNow / Switch Port dataset

Error verification

No other error verification information is applicable.

Cause

The Out-of-the-box ServiceNow configuration for the IP Switch Configuration Item related lists includes the “Switchport” [dscy_switchport] table. CI Sync writes switch port records to the “Switch Port“ [cmdb_switch_port] table.

Fix

Reconfigure the related lists for IP Switch:

  1. In ServiceNow, navigate to any switch record, right-mouse click in the header banner and select Configure/Related Lists.

  2. image-20230515-063715.png

    Remove dscy_switchport (“Switchport → Configuration Item”) related list from cmdb_ci_ip_switch and replace it with cmdb_switch_port (“Switch Port → CMDB CI”) and click the Save button

    image-20230515-063728.png

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Control Information

Created

Reviewed

Data Classification

PUBLIC
Classified in accordance with the Syncfish Data Classification Framework