Troubleshoot - 403 Forbidden Error when processing some Manufacturer records

Error experienced

When running a Delta sync into a pre-production ServiceNow instance:

  • some Manufacturer records are rejected with error

403 - Forbidden, Operation Failed - Error during insert of core_company (Hewlett-Packard)

NB: “Hewlett-Packard” is an example of the company name that was rejected by ServiceNow.

This KB applies to:

Applies to Versions

All

Applies to Source Connectors

All

Applies to Destination Connectors

ServiceNow

Error verification

No other error verification information is applicable.

Cause

This problem occurs under the following conditions:

  1. The ServiceNow Instance has the Normalization Data Services plug-in enabled.

  2. The ServiceNow Instance has been cloned from Production

  3. A Full synchronization has NOT been run following the Clone

This results in the CI Sync Search Keys table NOT containing all records that exist in ServiceNow. As a result, CI Sync is attempting to insert company records into ServiceNow that already exist. The Normalization Data Services Plug-in prevents duplicate company records which is returned to CI Sync as a 403 Forbidden response.

Fix

Run a Full Sync (that includes the Reference - Manufacturer Recorsdet. e.g. for Lansweeper, select “Apple Mac”).

Fix verification

When the Full sync has completed, locate the “Reference - Manufacturer” sync task and verify all records were processed successfully.

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Control Information

Created

Reviewed

Data Classification

PUBLIC
Classified in accordance with the Syncfish Data Classification Framework