Error experienced
When using CI Sync Agent Configuration utility to validate a connection the following error occurs:
Error azure authentication: Certificate not found
Error verification
Cause
This error can occur if the Certificate Subject (sometimes referred to as the Certificate Name) contains carriage returns when stored in the Windows Certificate Store.
The Subject name of certificates typically include multiple values that compose the distinguished name information, such as common name, country, organization, etc. When certificates have multiple values, the certificate Subject will typically include carriage returns when displayed in the Windows Certificate Store.
If the Subject name in the Windows Certificate Store includes carriage returns it impacts the way the CI Sync Config Utility is able to search and find the certificate using the Certificate Name value you enter into the CI Sync Config Utility.
In these circumstances you will need to construct the certificate name in a particular manner when you enter it into the CI Sync Config Utility (as described in the Fix section below).
Fix
The individual values of the Subject (as they appear in the Windows Certificate Store) need to be converted into comma separated values and also have the blank spaces trimmed before and after the equal sign (as per the example below).
You then need to copy/paste the newly formatted string value into the Certificate Name field in the CI Sync Config Utility UI form and execute a Test Connection once again.
The example below shows how to construct the correct format:
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Locate the certificate in the Windows Certificate Store and click the Subject field.
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Copy the content of the Subject field into text editor. It will appear (in the text editor) including carriage returns as shown below.
CN = CISyncDemoCert
O = Demo Group
C = AU
E = demo@syncfish.com.au
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Edit the Subject string and change the format as shown below:
CN=CI SyncDemoCert, O=Demo Group, C=AU, E=demo@syncfish.com.au
Important
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The blank spaces must be removed before and after each equal sign.
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A single space must be entered after each comma.
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Make sure there is no trailing space at the very end of the string.
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Return to the CI Sync Config Utility UI and paste the newly constructed string into the Certificate Name field as shown below. Click the Connect button under the Test Connection section of the UI.
If in doubt refer to the section below of the setup guide:
Task 5b: Use the CI Sync Agent Config Utility to test the connection values and register the CI Sync Agent with your CI Sync SaaS Instance.
Related articles
https://support.syncfish.com.au/cs/ckb042-troubleshoot-cisync-agent-configuration-con
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