Troubleshoot - Error - No such host is known

Error experienced

"error extractor api statusCode null: No such host is known"

This KB applies to:

Applies to Versions

All

Applies to Source Connectors

All

Applies to Destination Connectors

All

Error verification

When reviewing the Log files in C:\Program Files\CISyncAgent\logs, this error references an issue finding the host:

image-20220127-234548.png

Cause

This is due to a misconfigured URL in the appsettings.json file in C:\Program Files\CISyncAgent

image-20220127-234858.png

Fix

On the server hosting CI Sync (EE) agent

  1. Go to Windows Services.

  2. Locate and stop the CI Sync (EE) LS Agent Service.

  3. Go to the appsettings.json file and correct the URL setting https://<yoururl>.syncfish.com.au/extractor then save the file.

  4. Restart the CI Sync (EE) LS Agent Service.

  5. Review the log file again.

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Control Information

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Data Classification

PUBLIC
Classified in accordance with the Syncfish Data Classification Framework