Troubleshoot - Configuration Utility Connection Registration Error

Error experienced

When a connection is attempted to be registered using the Configuration Utility and an error is displayed

“Connection with connectionId *** or label *** already exists for agent ID…”

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This KB applies to:

Applies to Versions

All

Applies to Source Connectors

All

Applies to Destination Connectors

All

Error verification

No other error verification information is applicable.

Cause

This problem can occur via the following scenarios:

  1. A new Connection is created with a name that has been already used by a different registered Connection.

  2. A Connection has been updated back to Draft on appsettings.json but the application database still has a reference to the same connectionId.

  3. A Connection with the same name has been deleted from appsettings.json but the application database still has a reference to the connection name.

Fix

Scenario 1:

Rename the draft connection with a new name and attempt to register again.

Scenarios 2 & 3:

If manipulation of appsettings.json caused a connection to still have a reference, contact Syncfish Support to clear the connection from the application database.


Related Articles

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Control Information

Created

Reviewed

Data Classification

PUBLIC
Classified in accordance with the Syncfish Data Classification Framework