Troubleshoot - "error": "Agent:SQLserver01 Version:x-cise-agent-ver/2.2.0.0 Error:A network-related or instance-specific error occurred while establishing a connection to SQL Server

Error experienced

"error": "Agent:SQLserver01 Version:x-cise-agent-ver/2.2.0.0 Error:A network-related or instance-specific error occurred while establishing a connection to SQL Server. The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured to allow remote connections. (provider: SQL Network Interfaces, error: 26 - Error Locating Server/Instance Specified)"

This KB applies to:

Applies to Versions

All

Applies to Source Connectors

All

Applies to Destination Connectors

All

Error verification

No other error verification information is applicable.

Cause

This error can be caused by any of the below occurring.

  • Permissions modification of the account used to run the CI Sync (EE) Agent service in SQL.

  • Removal of the account used to run the CI Sync (EE) Agent service in SQL.

Fix

Database Permissions

  1. Obtain the user account running the CI Sync (EE) Service on the Lansweeper server.

  2. Login to the SQL server hosting the CI Sync (EE) database and the lansweeper database

  3. Open SQL Server Management Studio

  4. Expand the cise_ls_ver database > Security > Users and ensure the account running the CI Sync (EE) service on the Lansweeper server has access to this database.

  5. Ensure that account under membership has the db_datareader and db_datawriter for the cise_ls_ver database

    image-20230328-074129.png
  6. Ensure that account under membership has the db_datareader for the lansweeperdb database

    image-20230328-074405.png
  7. On the Lansweeper server restart the CI Sync (EE) service.

  8. Login to the CI Sync Web UI and go to Settings and check the Source Server is OK

    image-20230328-075118.png
  9. Perform a Sync to confirm CI Sync (EE) is performing correctly again.

Database Port

  1. Login to SQL Server and open Sql Server Configuration Manager

    image-20230331-013136.png
  2. Expand SQL Server Network Configuration > TCP/IP and right click and choose Properties

    image-20230331-013645.png
  3. Click on IP Addresses tab and confirm the TCP Port being used.

    image-20230331-013842.png

If the port has been changed from the default of 1433 the new port will need to be reflected in the appsettings.json


  1. Logon to the Server hosting CI Sync (EE) and go to the folder hosting the agent such as C:\Program Files\CISyncAgentLansweeperPROD\ then open appsettings.json

  2. If the default SQL port has changed please add the entry <SQLserver,port> to the “Server” section of the file as per below as an example.

    image-20230331-030543.png
  3. Save the appsettings.json file and then restart the CI Sync (EE) Windows service

  4. Check the C:\Program Files\CISyncAgentLansweeperPROD\Logs folder and most recent file for any errors

  5. Perform a Sync to confirm the instance is all OK

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Control Information

Created

Reviewed

Data Classification

PUBLIC
Classified in accordance with the Syncfish Data Classification Framework