Troubleshoot - Job fails with Deadlock error

Error experienced

The Job completed with one or more errors:

Error - Agent:itr-assets-eud Version:x-cise-agent-ver/3.2.31 Error:Workflow Faulted: Workflow Stack -> worker.get-task -> extraction.sql.upsertDelete -> extraction.sql.default FaultedActivty: d994696c-37ed-492b-a0ab-3deed8bd9805 Exception Type: System.Data.SqlClient.SqlException Message: Transaction (Process ID 389) was deadlocked on lock resources with another process and has been chosen as the deadlock victim. Rerun the transaction. Data: {"HelpLink.ProdName":"Microsoft SQL Server","HelpLink.ProdVer":"15.00.2120","HelpLink.EvtSrc":"MSSQLServer","HelpLink.EvtID":"1205","HelpLink.BaseHelpUrl":"https://go.microsoft.com/fwlink","HelpLink.LinkId":"20476"}

This KB applies to:

Applies to Versions

  • Agent version is less than 3.2.33

  • Configuration version is less than 1.0.62

Applies to Source Connectors

All

Applies to Destination Connectors

All

Error verification

No other error verification information is applicable.

Cause

The Customer SaaS is running one or both of the below:

  • An Agent with version less than 3.2.33 and/or

  • Configuration version in the SaaS environment is less than 1.0.62.

Fix

  • The Customer will need to upgrade Agents to 3.2.33 or later.

  • Configuration version 1.0.62 or later will need to be deployed into the Customer’s SaaS environment.

Please raise a request via Syncfish Support to assist with updating the Configuration Version.

There are currently no related articles.

Control Information

Created

Reviewed

Data Classification

PUBLIC
Classified in accordance with the Syncfish Data Classification Framework