Troubleshoot - Job fails with Agent Error "Failed to generate SSPI context"

Error experienced

CI Sync job fails with the error

Agent:{Agent Name} Version:x-cise-agent-ver/{Agent Version} Error:Failed to generate SSPI context

This KB applies to:

Applies to Versions

All

Applies to Source Connectors

All

Applies to Destination Connectors

All

Error verification

No other error verification information is applicable.

Cause

“Failed to generate SSPI context” is a SQL integrated security authentication problem. This would suggest that there’s a problem with the user account running the CI Sync Windows Server not being able authenticate with the SQL Server instance.

Fix

  1. It can be caused by the CI Sync Agent Service User Account credentials being incorrect. e.g. the password for the service account has been changed or expired in Active Directory and NOT updated in the Windows Service Log on settings.

  2. This error can also be intermittent and resolve itself.

  3. For more information, refer to the following Microsoft article:
    Cannot generate SSPI context when connecting to SQL Server - SQL Server | Microsoft Learn


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Control Information

Created

Reviewed

Data Classification

PUBLIC
Classified in accordance with the Syncfish Data Classification Framework