Troubleshoot - New Agent errors on startup "Access to the path is denied".

Error experienced

When the new Agent starts it throws error:

“Access to the path is denied.”

This KB applies to:

Applies to Versions

All

Applies to Source Connectors

All

Applies to Destination Connectors

All

Error verification

Open the Windows Application Event Log and verify that the following error is present:

Application: agent.worker.exe
CoreCLR Version: 7.0.22.51805
.NET Version: 7.0.0
Description: The process was terminated due to an unhandled exception.
Exception Info: System.UnauthorizedAccessException: Access to the path is denied.
   at System.IO.Pipes.NamedPipeServerStream.Create(String pipeName, PipeDirection direction, Int32 maxNumberOfServerInstances, PipeTransmissionMode transmissionMode, PipeOptions options, Int32 inBufferSize, Int32 outBufferSize, PipeSecurity pipeSecurity, HandleInheritability inheritability, PipeAccessRights additionalAccessRights)
   at System.IO.Pipes.NamedPipeServerStreamAcl.Create(String pipeName, PipeDirection direction, Int32 maxNumberOfServerInstances, PipeTransmissionMode transmissionMode, PipeOptions options, Int32 inBufferSize, Int32 outBufferSize, PipeSecurity pipeSecurity, HandleInheritability inheritability, PipeAccessRights additionalAccessRights)
   at Worker.PipeServer.ServerThread() in C:\Users\Administrator\cisee\agent\agent.worker\src\PipeServer.cs:line 52

Cause

The Account the Agent service is running as doesn’t have sufficient permissions to run the named pipe services and connect to the Windows Credential Store.

Fix

Make the service account user a member of the “Users” group.

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Control Information

Created

Reviewed

Data Classification

PUBLIC
Classified in accordance with the Syncfish Data Classification Framework