Troubleshoot - Unable to create/update connection because a partial match exists

Error experienced

“Unable to create/update connection because a partial match exists”

This KB applies to:

Applies to Versions

All

Applies to Source Connectors

All

Applies to Destination Connectors

All

Error verification

When in CI Sync (EE) under settings you do not see the server under connections or a different server than the one you are using.

image-20230320-233550.png
image-20230320-234905.png

Confirm the collector application is operational and also check in Services that the CI Sync (EE) LS Agent service is started.

image-20220127-235230.png

Go to C:\Program Files\CISyncAgent\logs and open the most current log and check for errors as shown below.

image-20220127-232435.png

Cause

The error Unable to create/update connection because a partial match exists is a result of another server running CI Sync (EE) with the same setup details configured in the appsettings.json file.

On the server with the issue go to C:\Program Files\CISyncAgent and open appsettings.json file and check the ClientID.

image-20220128-004812.png

Fix

The solution is another Application registration is required because you cannot run two (2) CI Sync (EE) instances that are registered to the same Enterprise App Registration.

  1. Create a second Enterprise App Agent registration

  2. Update the appsettings.json file with the new ClientID and Secret.

  3. Start the service.

  4. Check the log file and then refresh the browser and the source connector server should now be registered.

image-20220128-011508.png

There are currently no related articles.

Control Information

Created

Reviewed

Data Classification

PUBLIC
Classified in accordance with the Syncfish Data Classification Framework