Troubleshoot - ServiceNow returned 401 - unauthorized, required to provide auth information

Error experienced

Error - “servicenow returned 401 - unauthorized, required to provide auth information”

This KB applies to:

Applies to Versions

All

Applies to Source Connectors

All

Applies to Destination Connectors

ServiceNow

Error verification

image-20220127-233438.png

Cause

This error can be caused by any of the below occurring.

  • Reset of your ServiceNow instance or clone overwriting the existing instance

  • Change to the account used by CI Sync (EE) in ServiceNow or its groups/permissions

Fix

  1. Go to your CI Sync (EE) instance and go to Settings and then under your ServiceNow connections click on Update

image-20230320-235838.png
  1. Depending on the Authentication type in use update the password and if using the oauth the Client id and secret. Then click I consent to update these fields - Password and click Save connection

image-20220127-234018.png
image-20230313-065402.png
  1. Ensure the update to the connection was successful

image-20230320-235936.png

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Control Information

Created

Reviewed

Data Classification

PUBLIC
Classified in accordance with the Syncfish Data Classification Framework