Troubleshoot - Unable to create job - Destination connection ‘<servername>’ does not have environment ‘prod’

Error experienced

“Unable to create job - Destination connection ‘<servername>’ does not have environment ‘prod’”

This KB applies to:

Applies to Versions

All

Applies to Source Connectors

All

Applies to Destination Connectors

All

Error verification

No other error verification information is applicable.

Cause

When a scheduled job runs and does not have the Environment set it will return the error because there is no environment set for Prod or Test.

Fix

  1. Login to the web UI and go to Settings and look at both the Source Connections and Destination Connections and under the Environment variable it needs to have a value of test or prod or if the source server is used for both test and prod then it will say prod,test

    image-20221222-022614.png
  2. On the Source Connections click Update

    image-20221222-021955.png
  3. Under Environments from the drop down list choose what the source connection is, if it is Test, Prod or both.

    image-20221222-023022.png
  4. Once chosen tick the “I consent to update these fields and click Save connection

    image-20221222-022339.png
  5. The Environment on the Source connection will now be set

    image-20221222-023328.png
  6. On the Destination connections click on Update

    image-20221222-023423.png
  7. Under the Environment choose the Production or Test Environment

    image-20221222-023727.png
  8. Once chosen tick the “I consent to update these fields and click Save connection

    image-20221222-023829.png
  9. The Environment on the Source connection will now be set

    image-20221222-024129.png


Scheduled Jobs

  1. Go into the scheduled jobs and edit the job and confirm the correct Environment is set

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Control Information

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Data Classification

PUBLIC
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